ExtBase

With ExtBase you can develop new TYPO3 extensions for TYPO3 version 4.

It can be used from TYPO3 version 4.3 and it replaces the current way of extension building.

Why is that?

FLOW3 is the development framework for the new TYPO3 version 5 and it's extensions. To be ready for version 5 and the version 5 way of extension building with FLOW3, ExtBase is developed. ExtBase makes it possible to run version 5 extensions that are developed in FLOW3 to run in your TYPO3 version 4 web site!

Please note that there will be small differences between an extension that is being built for version 4, but it makes the adaptation of version 5 far more easy!

 

Follow us on twitter