ExtBase

Met ExtBase kun je de met FLOW3 ontwikkelde TYPO3 extensies geschikt maken voor TYPO3 versie 4.

Het kan gebruikt worden vanaf TYPO3 versie 4.3 en het vervangt de huidige manier van extensie ontwikkeling.

Waarom is dat?

FLOW3 is het ontwikkel framework voor de nieuwe TYPO3 versie 5 en de extensies. Om nu al klaar te zijn voor versie 5 en de versie 5 manier van extensies ontwikkelen met FLOW3, is ExtBase ontwikkeld.

ExtBase maakt het dus mogelijk om je versie 5 uitbreidingen die zijn ontwikkeld in FLOW3 te draaien in je TYPO3 versie 4 website!

Houdt u er rekening mee dat er kleine verschillen zijn tussen een extensie die wordt gebouwd voor versie 4 of voor versie 5, maar het maakt de migratie naar versie 5 straks veel gemakkelijker!

Follow us on twitter